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COMP1000 / Spreadsheets – Reminders

• The COMP1000 home page is at 

https://webcms3.cse.unsw.edu.au/COMP1000/17s1/

• Check notice regularly.

• You need to set up a School of CSE computing account to do the 

lab classes in COMP1000.

• You need a password to access parts of the COMP1000 web site.

https://webcms3.cse.unsw.edu.au/COMP1000/17s1/
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COMP1000 / Spreadsheets – Labs

• We can’t cover every details in the lecture. Instead, we’ll just give 

an overview of how to use Excel.

• We encourage you to finish the assignments prior to labs. 

• In the labs, tutors are only responsible for marking and answering 

major issues. 

• Labs cannot be handed in late – they have to be marked by the 

demonstrator during the lab time.

• Email submission is not allowed (except this week). 

• You can request to change the lab time if you’re sick or there’re 

other emergences. But you need to wait for available computers. 
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COMP1000 / Spreadsheets – Week 1 Review

• Enter and edit data

• Create and manage spreadsheets

• Functions such as IF, VLOOKUP, PMT…
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COMP1000 / Spreadsheets – Week 1 Review

• Produce a table of loan repayments for a loan:

- Principal = $1,000,000

- Terms from 20 to 30 years (one-year steps)

- Interest rates from 4.5% to 7.5% p.a. (0.5% steps)

• Demonstration…
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Objectives

• Decide which chart type to create

• Create a chart

• Change the chart type

• Change the data source and structure

• Apply a chart layout and style

• Move a chart
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Objectives (continued)

• Print charts

• Insert and customize a sparkline

• Select and format chart elements

• Customize chart labels

• Format axes and gridlines

• Add a trendline
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Chart Basics

• A chart is a visual representation of numeric data
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Chart Basics

• Chart components include:

– Each cell containing a value is Data Points

– A group of data points that appear in rows or columns 

create a Data Series

– Textual information, such as column and row labels 

(college names, years etc.) is used to create Category 

Labels
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Chart type

• Column charts (clustered, stacked, 3-D, etc.)

• Bar chart

• Line chart

• Pie chart

• Scatter chart

• Stocker chart

• …
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Column Charts

• A column chart displays data vertically, with each data 

series forming a column

x-axis or 

Category axis

y-axis or Value axis
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Clustered Column Chart

• Insert tab / Charts group / Column / Clustered Column 
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Reversing Categories and Data Series

• Chart Tools / Design tab / Data group / Switch Row & Column
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Stacked Column Chart

• Insert tab / Charts group / Column / Stacked Column 
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100% Stacked Column Chart

• Insert tab / Charts group / Column / 100% Stacked Column 
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3-D Column Chart

Non-horizontal axis can make comparisons difficult: avoid.
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Bar Chart

This bar chart has fancy bars (Chart Tools / Design / Chart Styles).
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Line Chart

• Insert tab / Charts group / Line button / Line



COMP1000 © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G Spreadsheets  slide 18

Pie Chart
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X Y (Scatter) Chart

Demo:scatter
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Surface Chart
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Creating a Chart

• Select the data source

• Select the chart type

• Position and size the 

chart
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Changing the Chart Type

• Using the Chart Tools contextual tab:

– Click the Design tab

– Click Change Chart Type

– Select the desired chart type
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Changing the Data Source

• To modify the chart data source:

– Click the Design tab

– Click Select Data under the Data group
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Moving a Chart

• To move a chart:

– Click the Design tab

– Click Move Chart under the Location group
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Printing a Chart

• To print an embedded chart:

– Select the chart

– Click the File tab

– Click Print to display the Backstage view

– Use the Print Selected Chart option

• To print a chart sheet:

– Use the Print Active Sheet option
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Creating a Sparkline

• A sparkline is a miniature chart displayed in a single cell 

• Click Insert tab / Sparklines group / Line | Column | Win/Loss

• Dialogue box like that above comes up 

• Demo: college major
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Chart Layout

• The Layout tab offers many ways to enhance a chart 

visually

Chart elements arrow – the label in the box will be 

the most recently selected chart element.
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Selecting and Formatting Chart Elements

• Formatting a chart 

element:

– Right-click the element 

and select the Format 

element command

– The element portion 

will change depending 

on the selection (ex. 

Format Data Series)
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Customizing Chart Labels

• Click Chart Tools / Layout / Labels / Data Table
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Chart Titles and Legend

• A chart title is the label that describes the entire chart

• An axis title is a label that describes either the category or value 

axis. Always use axis titles.

• A legend is used to identify sectors in a pie chart or data series in 

a multiple series chart. Make labels in a legend meaningful.
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Data Labels

• A data label is the value or name of a data point
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Axes and Gridlines

• Excel computes starting, ending, and incremental values 

for display on the value axis

• A gridline is a horizontal or vertical line through the plot 

area

• Chart Tools / Layout / Axes / Gridlines / …

• Chart Tools / Layout / Axes / Axes / Primary Vertical Axis / 

Show axis in millions
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Trendline

• Trendline: to depict trends or forecast future data

Demo:trendline
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Summary

• In this chapter, you have learned to create charts such as 

column, bar, pie and line charts.

• You can modify an existing chart by changing the chart 

type, location or data source.

• You can insert, remove, and format chart elements such as 

titles, labels, and the legend.
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Copyright 
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Grauer Chapter 4 – Excel Datasets and Tables

Objectives

• Freeze rows and columns

• Print large datasets

• Understand table design

• Create a table

• Apply a table style

• Sort data
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Objectives (continued)

• Filter data

• Use structured references and a total row

• Apply conditional formatting

• Create a new rule

• Sort and filter using conditional formatting
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Large Datasets

• A large dataset can be 

difficult to read 

– Row and column 

headings may scroll off 

the screen
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Freezing Rows and Columns

• Freezing keeps rows and columns visible during scrolling

• View tab / Window group / Freeze Panes button gives you 

these choices:

Option Description

Freeze Panes Keeps both rows and columns above or to the left of the 

active cell visible.

Freeze Top Row Keeps only the top row visible.

Freeze First Column Keeps only the first column visible.
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Freezing Rows and Columns

• Figure 4.2 illustrates the effect of freezing rows 1 – 5 and 

columns A – B

Click cell below and to the right of columns & rows to be frozen.

View tab / Window group / Freeze Panes …
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Excel Tables

• A table is a structured range of related data formatted to 

enable data management and analysis

• Excel tables offer many features not available to regular ranges

– Calculated columns cause a formula or function written in a 

column to be automatically copied down the column

– Total rows allow easy calculation of sum, average, count, 

min, max, …

– Can use column header name in formulae
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Table Design

• A field is an individual piece of data

– Field names appear in the top row as column headings

– Field names should be short, but descriptive

• A record is a complete set of data for an entity

– Each record is listed in a row of the table

– Do not insert blank rows in the table
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Creating a Table

• A table can easily be created from existing data
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Creating a Table

• The Design tab on the Table Tools contextual tab opens when 

the table is selected

• Demonstration…

• Click in data range. Insert tab / Tables group / Table

• Check range, tick “table has headers” if necessary. Click OK.
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Adding Records

• Add a new record at the bottom of the table by clicking in the 

row under the table

• Add a new record within the table by clicking in the record 

below the insertion point

– Click the Home tab

– Click the Insert arrow in the Cells group

– Select Insert Table Rows Above
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Editing and Deleting Records

• Data within a table record can be edited using the same 

techniques as those for a regular cell

• Deleting a record removes it from the table

– Click the Home tab

– Click the Delete arrow in the Cells group

– Select Delete Table Rows
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Deleting Records, continued

• Delete records with extreme caution.

• Excel has a procedure for removing duplicate records. 

(Table Tools / Design / Tools / Remove Duplicates) 

However…

• If you have two records with the same transaction number 

but different details, and you delete based on duplicate 

transaction number, how do you know that Excel will pick 

the correct one to delete? Excel does give you the chance to 

specify that only identical records should have their duplicate 

removed.
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Applying a Table Style

• A table style 

controls the fill 

color of the header 

row, columns, and 

records
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Table Style Options

• The Table Styles Options group on the Design tab contains 

check boxes to further format the table

Check Box Action

Header Row Displays the header row at the top of the table.

Total Row Displays a total row at the bottom of the table.

First Column Applies a different format to the first column.

Last Column Applies a different format to the last column.

Banded Rows Displays alternate fill colors for even and odd rows.

Banded Columns Displays alternate fill colors for even and odd columns.

• Table Tools / Table Styles / More button
• Demonstration …
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Table Manipulation and Aggregation:

Sorting Data

• Sorting arranges records in a table

– Sort on one column

– Sort on multiple columns

• Records can be sorted into ascending or descending order
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Sorting by One Column

• Excel offers several ways to sort a single column

Data 

type

Options Explanation

Text Sort A to Z Arranges data in alphabetical order.

Sort Z to A Arranges data in reverse alphabetical order.

Dates Sort Oldest to Newest Displays data in chronological order.

Sort Newest to Oldest Displays data in reverse chronological 

order.

Values Sort Smallest to Largest Arranges values in sequential order.

Sort Largest to Smallest Arranges values in descending order.

• Home tab / Editing group / Sort & Filter, or

• Data tab / Sort & Filter / Sort A to Z | Sort Z to A | Sort
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Sorting by Multiple Columns

• Multiple level sorts permits differentiation among records 

with duplicate data in the first sort.

• Click in table, click in Data / Sort&Filter / Sort

• Click Sort By arrow, select Payment Type, click Add Level

• Click Then By arrow, select Transactions, click Add Level

• Click Then By, Amount, Order arrow, Largest to Smallest, OK.

Demo…
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Creating a Custom Sort

• A custom sort can be 

created to arrange 

values in a 

customized fashion

• See textbook for 

details.
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Filtering Data

• Filtering is the process of displaying only records that meet 

specific conditions
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Filtering Data - Demo

• Click Sales Rep Last Name filter arrow

• Click (Select all) check box to deselect

• Click the McGuire check box, click OK

• Now only McGuire records show (27/70)

• Click Manufacturer filter arrow

• Click Serenity Spas check box to deselect, click OK

• Now only McGuire sales of spas other than Serenity show 

(22/70)
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Filtering Numeric Data

• Numeric filters can be applied to display a range of values

• Select H6:H75, Click Amount filter arrow

• Point to Number Filters, select Greater Than Or Equal To, type 
10000 in box to right, click OK

• Down to 7 spas sold that meet these filters.
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Using Structured References

• A structured reference is a tag or table field name used in a 

formula or function

• Type “=[Amount]-[Down Payment]” in J6, rather than “=H6-I6”.

• Computation is done for whole column.
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Creating a Total Row

• A total row appears as the last row of a table and offers 

statistical functions

• Table Tools Design tab / Table Style Options group / Total 

Row check box.
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Conditional Formatting

• Highlights cells whose contents meet some condition.

• Home tab / Styles group / Conditional formatting

Conditional 

Formatting

Description

Highlight Cell Rules Highlights cells with a fill color, font color or border if the 

cell value satisfies the rule.

Top/Bottom Rules Formats cells with values in some top number or percentage.

Data Bars Applies a gradient or filled bar in which the width of the bar 

represents the cell’s value with respect to other cells.

Color Scales Formats different cells with different colors, assigning one 

color to lowest and highest groups and gradient colors in 

between values.

Icon Sets Inserts an icon in a cell to indicate values compared to each 

other.
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Applying the Highlight Cells Rule

• Demonstration…
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Highlight Cells Demo

• Demonstration…

• Select rows 6-75 in January Range worksheet

• Click Home / Fill color arrow(=bucket) / No Fill, if necessary

• Select D6:D75, Home / Styles / Conditional Formatting / Highlight 

Cells Rules / Text That Contains

• Type Fairbanks in the box, click the With arrow, select Green Fill 

with Greet text, click OK.

• Next select H6:H75, Conditional Formatting / Top/Bottom Rules / 

Top 10 Items

• Click arrow to display 5, click With arrow, select Light Red Fill, OK

• Next select I6:I75, Conditional Formatting / Data Bars and select 

Purple Data Bar in the Gradient Fill section.

• Save the workbook. Always.

• More in textbook (p 273-4). More in loan-table workbook.
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Applying the Top/Bottom Rules
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Displaying Data Bars, Color Scales, and Icon Sets
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Creating a New Rule

• The New Formatting Rule dialog box is used to create a 

customized rule
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Sorting and Filtering Using Conditional 

Formatting

• It is possible to apply sorting and filtering commands to data 

using a conditional filter

– Use the Sort by Color option to group highlighted records

– Sort the field in ascending order to arrange data bars

– Use the Filter by Color option to display only highlighted 

records
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Printing Large Datasets

• The Page Layout tab offers options to help print large datasets:

– Page Breaks (Page Layout tab / Page Setup group / Breaks)

– Print Area (Page Layout tab / Page Setup group / Print Area)

– Page Titles (Page Layout tab / Page Setup group / Print Titles)
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Manual Page Breaks

• A page break 

indicates where data 

will start on a new 

printed page

• To set a manual 

page break, click 

the new first-cell-on-

page; click Page 

Layout tab / Breaks / 

Insert Page Break.
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Setting a Print Area

• A page area defines the range of data to print.

• Select area you want to print; Page Layout tab / Page Setup 

group / Print Area / Set Print Area.
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Print Titles

• Print titles indicate 

some rows or columns 

that will repeat at the 

top or side of each 

printed page.

• Page Layout tab / Page 

Setup dialogue box 

launcher (arrow) / 

Sheet tab / Page order 

section.
• Demonstration…
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Summary

• In this chapter, you have learned to manage large datasets by 

freezing rows and columns and controlling print options.

• You understand table design and can create and format a table.

• You can sort and filter data in a table.

• You can use structured references in formulas and apply 

statistical functions in a total row.

• You can apply conditional formatting to add emphasis to 

records.
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Data Analysis using 

COMP1000 Spreadsheets, Databases, Web

Data Analysis using Excel (Not included in exams!)  

 Data Analysis

 Histogram

 Descriptive Statistics

 Correlation

 Fitting Equations to Data
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Data Analysis using 

Data Analysis

• Data analysis techniques allow professionals like engineers, 
social scientists and economists to extract meaningful 
information from a (typically) vast amount of data. 

• Excel is widely available, and provides useful 
functions/features for data analysis. 

• Some of these functions/features include:
• Histogram

• Descriptive Statistics

• Correlation

• Regression Analysis
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Data Analysis using 

Analysis Toolpak in Excel

• Analysis Toolpak is an add-in package for Excel. You need to activate it 

using   Excel Options/Add-Ins (via the File menu in Excel 2010, 

or the Office button in 2007).

• Make sure that both the Analysis ToolPak and Solver Add-in are in 

the “Active Application” list, otherwise click Manage Add-ins.

• For more info see “Enable or disable add-ins” in “Excel Help”.

• The Analysis Toolpak provides tools to help users to quickly and easily 

carry out reasonably complex data analysis tasks. 

• It provides support for many popular statistical and engineering data 

analysis tasks.

• Note: Excel's statistics algorithms are not sufficiently robust for use by professional 

statisticians (but they're OK for normal purposes)
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Data Analysis using 

Histogram

• A histogram is a graphical representation of a frequency distribution. 

• A process of creating a histogram requires a user to provide “bin” values. Data 

values are aggregated/separated into classes based on these bin values. In a 

histogram, each bar represents one bin, and the height of the bar represents the 

frequency of that bin.  

Bins
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Data Analysis using 

Descriptive Statistics
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Data Analysis using 

Correlation

• Correlation is a statistical measure referring to the strength of 

linear relationship between two or more variables

• It can vary from 1 (perfect negative correlation) through 0 (no

correlation) to +1 (perfect positive correlation)

• Excel provides a tool called “Correlation” that can calculate 

correlations between two or more variables. 

• Alternatively, a user can plot a chart for two or more variables 

and try to visually identify possible correlations between 

variables.
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Data Analysis using 

Fitting Equations to Data

• The method of least squares tries to fit a curve (including a straight line) through an 

aggregate of data. It tries to find a simple relationship among variables and express 

the relationship as an equation.

• The “best-fit” curve is the one that minimises the sum of the squares of the residuals 

(differences between data and the predicted value).

• Two approaches in Excel: 

– Using “Trendlines” on charts (preferred for casual use)

– Using the “Regression” tool (gives more stats)

• If we do not need a lot of information about the regression, we can use Trendlines

on charts. They provide the basic equation and R2 value, and show the regression 

line superimposed on the data values. 

• The R2 value (varies from 0 to 1) indicates how well the model fits the data. R2 = 1
indicates that the regression line (curve) is a perfect fit to the data. 

• See Topic 4 in the textbook. 
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Data Analysis using 

Fitting Equations to Data

Equation

R2 value

Trendline


