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COMP1000 / Spreadsheets – Week 2 Review

• Plot chart

• Column chart/bar chart/pie chart

• Customize chart

• Chart style/labels/titles

• Add trendline

• Create table

• Create table/apply different style/print table

• Sort/filter data
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Excel Comprehensive 

Chapter 5

Subtotals, Pivot Tables, 

PivotCharts
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Objectives

• Group and ungroup data

• Subtotal data

• Create a PivotTable

• Change the values field

• Modify a PivotTable

• Sort, filter, and slice a PivotTable

• Create a calculated field

• Format a PivotTable

• Create a PivotChart
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Group and Ungroup Data

• Group rows or columns of  related data into an 

outline

• Expand or collapse groups depending on your 

focus

• Excel will not create an outline or group data if  

the dataset does not contain a formula
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Group and Ungroup Data
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Subtotal Data

• Use Subtotal command to insert subtotal rows 
at each designated field change in a sorted range 
of  data 

– Subtotals calculated using summary functions

– Grand totals displayed after each group

– Additional levels of  subtotals can be inserted
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Subtotal Data

• Demonstration Outline

• Sort the data.

• Subtotal the data.

• Second subtotal.

• Collapse/expand subtotals.

• Outline / collapse data.

• Demo uses 

e05h1sociology.xlsx - available 

on COMP1000 home page 

(week 3 notes).
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Create a PivotTable

• A PivotTable allows you to summarize, analyze, and 

explore large amounts of  data

• Data can be dynamically arranged to view it from 

different angles

• One column must have duplicate values to create 
categories for organizing and summarizing data 

• Another column must have numeric values

• Create a PivotTable by clicking PivotTable in the 

Tables group on the Insert tab
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Pivot table Overview
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Create a PivotTable
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Create a PivotTable
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Create a PivotTable
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PivotTable Demo Overview

• (open worksheet &) create empty table

• Add row labels; add values; add columns

• Customize row and column names

• Update data sheet and then refresh PivotTable
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PivotTable Step-by-Step

• Open e05h1sociology; save with a different name;

• Books Data worksheet; click in data; then Insert/Tables/PivotTable;

• Range should be A4:L90, New Worksheet; click OK;

• Enter Book Analysis in PivotTable name box, ribbon top-left;

• Change the name of  the current worksheet to PivotTable;

• Go to PivotTable Fields list (at right); check Discipline in “Choose 

fields to add to report” – data is text so by default it goes in Row 

Labels. Or you could drag it there instead of  checking the box.

• Click Total Book Sales – data is numeric, by default it goes in Σ
Values;

• Drag Edition to Column Labels (what happens if  you just click it?)

• Drag Copyright to below Discipline in Row Labels area.
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PivotTable Step-by-Step 2

• Click Edition arrow in Column Labels area; select Remove Field;

• Drag Copyright field to Column Labels area;

• Click Options/Calculations/Summarize Values By/More options…

• “Sales by Discipline” in Custom Name box; click Number format;

• Click Accounting; 0 decimal places; OK;

• Click cell A4; type Discipline; Enter;

• Cell B3;  type Copyright Year; Enter;

• Centre headings in range B4:F4.

• Click Books Data worksheet tab; click J1; change to 125%; Enter;

• Click PivotTable worksheet tab; Click Options/Data/Refresh

• Save workbook.
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Change the Values Field

• Select the function used to calculate summary 

statistics

• Default is:

– Sum for values

– Count for text fields

• Specify a custom column heading

• Apply number formatting
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Change the Values Field
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Modify a PivotTable

• Add, remove, or rearrange fields to get a 

different perspective on the data

• Be careful not to make the data overwhelming 

with too many details

• Excel does not automatically update 

PivotTables: if  the underlying data is changed, 

you refresh the PivotTable by PivotTable 

Tools/Options/Data/Refresh

Demo:modify
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Sort, Filter, and Slice a PivotTable

• PivotTable data can be sorted.

– Default order is alphabetical by row label text

• To quickly rearrange data, click in a cell in the column you 
want to sort, and then click Sort Smallest to Largest (Sort 
A to Z for text) or Sort Largest to Smallest (Sort Z to A 
for text) in the Sort & Filter group on the Options tab.

• For specialized sorting, click Sort in the Sort & Filter 
group on the Options tab.

– If  you click in a row label or column label first, you get a 
dialog box with slightly different options from those you get 
if  you click on a value first 

Demo:sort
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Sort, Filter, and Slice a PivotTable
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Sort, Filter, and Slice a PivotTable
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Sort, Filter, and Slice a PivotTable

• Apply filters to show a subset of  data in a 
PivotTable

• Two types of  filters:

– A report filter sets the overall conditions for 
aggregating data

– A group filter filters out data based on a row or 
column category

• Filter by one or multiple items, as well as by 
entering a search condition
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Sort, Filter, and Slice a PivotTable

• Report Filter: to select one or more Editions to display.

• Drag Edition to Report Filter box, then click on arrow in B1.
Demo:filter
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Sort, Filter, and Slice a PivotTable

• Use slicers to filter data in a PivotTable

• Slicers:
– Are graphical

– Provide buttons that you can click for quick filtering

– Indicate the current filtering state

• To insert slicer, click the Options tab, click the 
Insert Slicer button in the Sort & Filter group, click 
one or more field check boxes for which you want 
to create a slicer, and then click OK

• To use slicer, click a button to filter data  
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Sort, Filter, and Slice a PivotTable

Demo:slice
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Create a Calculated Field

• Calculated field:

– Is a user-defined field

– Does not exist in the original dataset

• Use basic arithmetic operations, but not cell 

references or range names

• Click in PivotTable, Click Options/Calculations/Fields, 

Items & Sets/Calculated Field. Type a name for the new 

field in the Name box. In the Formula box, enter the 

formula for the field, e.g. Click Sales from the Fields list, 

then type *0.12, to calculate 12% of  Sales. Finally, click Add
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Create a Calculated Field
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Format a PivotTable

• Basic formatting applied to PivotTables:

– Primary row labels formatted in bold

– Subtotals are bold

• Use PivotTable Tools Design tab to apply a 
PivotTable style and control:

– Font color

– Fill color

– Bolding

– Border lines
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Format a PivotTable
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Create a PivotChart

• A PivotChart is a graphical representation of  
data in a PivotTable.

• You can create a PivotChart from a PivotTable 
or at the same time you create a PivotTable.

• Creating and customizing PivotCharts is similar 
to the methods used on regular charts.

• A PivotChart is interactive, meaning changes 
made in the associated PivotTable are 
immediately reflected in the PivotChart.
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Create a PivotChart
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PivotChart Demo Outline

• Apply a PivotTable style

• Create a PivotChart

• Change and enhance a PivotChart
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Summary

• In this chapter, you learned about the tools that 

help you manage large amounts of  data and 

translate that data into useful information. These 

include:

– Creating and modifying a PivotTable.

– Sorting, filtering, and slicing a PivotTable.

– Creating a PivotChart.
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Excel Comprehensive 

Chapter 6

What-if Analysis
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Objectives

• Create a one-variable data table

• Create a two-variable data table

• Describe ‘iteration’ in Excel

• Identify an input value with Goal Seek

• Use Scenario Manager

• Generate scenario summary reports

• Load the Solver Add-in

• Optimize results with Solver
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Overview
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Create a One-Variable Data Table

• What-if  analysis ─ allows you to see how 
changing variables impacts calculated results

• A variable ─ a value that can be changed to see 
how it affects other values

• A one-variable data table ─ a data analysis tool 
that provides various results based on changing 
one variable

• A substitution value ─ replaces the original value 
of  a variable in a data table
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Create a One-Variable Data Table

1. List substitution values in the left column or 

first row

2. Enter formulas in the first row or left column 

(whichever was not used above)

3. Create the one-variable data table 

4. Format the results of  the data table

5. Create custom number formats to disguise the 

formulas as headings
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Create a One-Variable Data Table

To complete a one-variable data table:

1. Select entire table starting in the blank cell in 

the top-left corner

2. Click What-If  Analysis in the Data Tools group 

on the Data tab and select Data Table 

3. Enter address of  the cell to be changed in the 

Data Table dialog box 

4. Click OK
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Create a One-Variable Data Table

Demo:autoloan
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Create a Two-Variable Data Table

• A two-variable data table ─ a data analysis tool that 
provides results based on changing two variables

• Creating a two-variable data table ─ similar to 
creating a one variable data table; however, you are 
limited to comparing one result. 

• Recommendations include:

– Use the top row for one variable’s substitution values

– Use the first column for the other variable’s values

– Apply a custom number format to the formula cell in 
the top-left cell
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Create a Two-Variable Data Table

Demo:autoloan
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Identify an Input Value

with Goal Seek

• Goal Seek ─ a tool when you know the desired 

end result but not the value needed to meet the 

goal

• Enables you to work backwards to solve a 

problem

• Excel can enter the input value in the variable 

cell
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Goal seek overview
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Goal Seek Demo

• Suppose we want to borrow money from a bank to buy a car

• We plan to pay $600 per month

• We want to know how much could we borrow.

Demo:goalseek
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Goal Seek – another example

• Suppose we want to solve an equation like 4x3 + 

12x2 – 64x + 16 = 0

• In Excel, you can plot the graph and estimate 

the roots.

• You can also use Goal Seek to find more exact 

roots.

Demo:equation
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Use Scenario Manager

• Scenarios take detailed sets of  input 

values and determine possible results

• Scenario Manager enables you to 

define and manage up to 32 scenarios

• Scenarios are maintained separately for 

each worksheet in a workbook
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Scenario Demo Outline

• Create a scenario

• Create more scenarios

• Generate/format a scenario report

Demo:scenario
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Load the Solver Add-in

• Solver ─ a separate program that must 
be installed or added in to Excel

• Once loaded ─ appears in the Analysis 
group on the Data tab

• Solver manipulates variables based on 
constraints to find the optimal solution 
to a problem



COMP1000 © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G
Spreadsheets-3  slide 50

Load the Solver Add-in

To load Solver:

1. Click the File tab, and then select Options

2. Click Add-Ins

3. Click the Manage arrow, select Excel Add-
ins, and then click Go to open the Add-
Ins dialog box

4. Click the Solver Add-in check box in the 
Add-Ins available list and click OK
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Load the Solver Add-in
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Optimize Results With Solver

• Solver requires three types of  info:

–Objective cell contains a formula-based 
value that you want to optimize that 
relates directly or indirectly to the 
changing cells and constraints 

–Changing cells are the cells whose 
values are adjusted until the constraints 
are satisfied 

–Constraints specify the restrictions
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Optimize Results With Solver

To specify the objective and changing cells:

1. Click Solver in the Analysis group on the Data tab to 
open the Solver Parameters dialog box

2. Enter the cell containing the formula for which you 
want to optimize its value in the Set Objective box

3. Click an option in the To section to specify what type of  
value you need to find for the target cell (such as Max, 
Min, or Value Of  with a specified value)

4. Enter the cell references that contain variables in the By 
Changing Variable Cells box
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Optimize Results With Solver
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Optimize Results With Solver

To specify the constraints:

1. Click Add to the right of  the Subject to the 
Constraints list to open the Add Constraint dialog 
box

2. Enter the cell reference, the operator to test the 
cell references, and the constraint the cell needs to 
match (such as the down payment must be less 
than or equal to $7,000)

3. Click OK to add the constraint and return to the 
Solver Parameters dialog box, or click Add to add 
the constraint and create another constraint
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Optimize Results With Solver
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Optimize Results With Solver

• Solver uses an iterative process to find an 
optimal solution

• A summary report can be generated if  a solution 
is found

• The report specifies:

– Binding Constraints which are rules that Solver 
enforced to reach the target value

– Nonbinding Constraints do not restrict the target 
value found
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Demo – Coffee shop

• Suppose you have a coffee shop

• You sell regular coffee, latte, and Mocha.

• The price and cost of  each type is different.

• You have limited materials (milk, cups etc.)

• You want to find how to maximize your profit.

Demo:solver
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Summary

• In this chapter, you learned that what-if  analysis 
is the process of  changing the values in cells to 
see how those changes will affect the outcome 
of  formulas on the worksheet. You can:

– Create a one- or two- variable data table.

– Use Goal Seek.

– Use Scenario Manager.

– Generate scenario summary reports.

– Optimize results with Solver.
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Objectives

• Work with grouped worksheets

• Manage windows and workspaces

• Insert hyperlinks

• Insert a 3-D formula

• Link workbooks
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Work with Grouped Worksheets

• Create worksheets with identical structure and 
formatting in the same workbook when data is 
similar but:

– Time periods differ

– Company locations differ

• Grouping selecting two or more worksheets so 
you can perform the same action at the same time

• When worksheets are grouped:

– Worksheet tabs display a white background color

– [Group] appears in the title bar

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 61



COMP1000 © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G
Spreadsheets-3  slide 62

Work with Grouped Worksheets
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Work with Grouped Worksheets

• To group:

– All worksheets: Right-click and then click Select All 
Sheets

– Adjacent Worksheets: Click the first worksheet tab, 
press and hold Shift, and then click the last 
worksheet tab

• To ungroup:

– Click any unselected worksheet tab

– Right-click any selected worksheet tab, and then click 
Ungroup Sheets

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 63



COMP1000 © Pearson Education 2011 or UNSW,  CRICOS Provider No: 00098G
Spreadsheets-3  slide 64

Work with Grouped Worksheets

• Grouping worksheets improves productivity by 

letting you perform the following tasks on each 

worksheet at the same time:

– Data Entry

– Structural Changes

– Formatting

– Page Layouts

– Printing

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 64

Demo:group
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Work with Multiple Workbook

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 65

• Hide/unhide

• Split: horizontal split/vertical split/cross split

• Compare two workbooks

– Switch windows

– Arrange all

– Side by side

Demo:multipleworkbook
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Work with Multiple Worksheets

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 66

• Compare two worksheets in the same workbook

– New Window

– View/new window/

Demo:multipleworksheet
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Insert Hyperlinks

• A hyperlink ─ an electronic marker 
that connects to a(n):

–Specific cell in the same workbook

–Specific cell in a different workbook

–Existing file

–Web page

–E-mail address

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 67
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Insert Hyperlinks
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Demo:multipleworksheet
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Insert a 3-D Formula

• To consolidate data from several 

worksheets:

–Use a worksheet reference 

–Create a 3-D formula

–Link data

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 69
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Insert a 3-D Formula
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Link Workbooks

• Consolidate data by linking workbooks

–Do not move or rename workbooks after 

creating a link

• Benefit of  linked workbooks a 

change made in one workbook (source 

file) is updated in the other workbook 

(destination file) 

Copyright © 2011 Pearson Education, Inc. Publishing as Prentice Hall. 71

Demo:linkworkbook
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Link Workbooks

• When you link files, you establish an external 
reference:
– Similar to a worksheet reference

–Must include the workbook name, including the 
extension, between brackets

–Default is that absolute cell references are 
created

–=[Cleveland.xlsx]'Qtr3'A1 creates a link to cell 
A1 in the Qtr3 worksheet in the Cleveland 
workbook. 
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Link Workbooks

• Excel displays formulas with external 

references in two ways:

–When the source workbook is open, the 

file name, worksheet, and cell reference 

display

–When the source workbook is closed, 

the full path displays
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Summary

• In this chapter, you learned to manage multiple 

worksheets and consolidate data.
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Macros and VBA

• Macro — a set of  instructions that tells Excel 
a sequence of  steps to perform

• File formats that support macros include:

– Excel Macro-Enabled Workbook (.xlsm)

• Good for automating routine but often-repeated 
tasks

• (VBA slides based on Material by Geoff  Whale)
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Create a Macro

• Macro Recorder — an Excel tool for 
recording a sequence of  steps. (These are 
stored in the VBA programming language).

• Remember:

– It records every action taken, so…

– Practice the steps before recording

–Make them broadly applicable 

• Use the correct cell references

– Relative, absolute, or mixed
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Use the Macro Recorder

Access the Macro Recorder by either:

–View tab: contains the Macros group with the 

Macros command

–Developer tab (when displayed)

– Status bar, which can display the Macro 

recording button …
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To Display the Developer Tab

To display the Developer tab:

• Click File / Options / Customize Ribbon / Developer

check box / OK
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To Add Macro Recording to the Status Bar

To add the Macro Recording icon to the status bar:

• Right-click the status bar

• Click Macro Recording

• Click outside the menu to close it.
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To Record a Macro

1. Click the View tab

2. Click the Macros arrow 

in the Macros group

3. Select Record

4. Type a name for the 

macro

5. Type a keyboard 

shortcut if  desired
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Recording a Macro (continued)

6. Click “Store macro in” 
arrow and select a 
location

7. Type a description and 
purpose

8. Click OK

9. Perform the commands

10. Click View tab, Macros in 
the macros group, and 
then Stop Recording
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Run a Macro

To run a macro:

1. Select the location 
where you will test the 
macro

2. Click the View tab

3. Click the Macros arrow 
in the Macros group

4. Select View Macros

5. Select the macro

6. Click Run
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Example Macro – Multiple Formatting Steps

• Select a non-empty cell (or similar) so you can 
monitor the changes as you record the macro.

• Start Macro recording (e.g. with status bar icon).

• Name it FormatCell, shortcut ctrl+Shift+F, OK.

• Bold the cell, centre the cell, change its background 
to yellow and its text colour to red, choose fontsize
16, and font Garamond.

• Stop Macro recording.

• Click Developer/Code/Macros, select FormatCell
and click Edit.

• Admire the VBA code. There’s a lot of  it. 
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Inspecting the Code in the VBA Editor
At left is part of  the VBA code from 

the Macro Recorder. Bits that actually 

matter are boxed in blue. Below is a 

simplified version of  the same code.

The red arrow shows how 

.Color = 65535 (i.e. yellow) shows 

up in the simplified version.
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Mid-exam and Final exam

• Two parts:

– Multiple choice

– Practical operations

• Knowledge (practical operations)

– Basic operations like add/delete row/column, change 

color/size, add a total row

– Basic functions like IF/COUNTIF/VLOOKUP/PMT

– Plot charts

– What-if  analysis
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